WPML ANSI_X3.4 erreur installation mbstring avec EasyApache sur WHM

Erreur à l’activation de WPML: charset `ANSI_X3.4-1968′ not supported

Je viens d’installer WPML sur un site et me rendant sur le plugin dans l’admin pour le configurer, il y avait cette notice en haut de la page:

Warning: filter_input(): charset `ANSI_X3.4-1968' not supported, assuming utf-8 in /home/altrumrecokarela/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/not-compatible-plugins.php on line 32

Je suis allé fouiller dans le forum de support de WPML pour comprendre que le problème provenait du fait que le module mbstring n’était pas installé sur le serveur.

Comme WHM/cPanel roule sur mon serveur, j’ai pu utiliser EasyApache pour installer le module manquant. EasyApache permet de mettre à jour et configurer Apache ainsi que, entre autre, PHP,

Pour ce faire, rendez-vous dans votre WHM et sélectionnez EasyApache. Puis, dans le profil DEFAULT, cliquez sur l’engrenage.

Installer mbstring avec EasyApache sur WHM

Suivez les étapes en cliquant sur le bouton Next et rendez-vous jusqu’à Short Options puis cliquez sur le bouton Exhaustive Options List. Cochez ensuite la case à côté de mbstring.

Finalement, cliquez sur le bouton Save and Build. Apache recompilera et en 5-10 minutes, tout sera de retour à la normale, avec mbstring activé et aucune erreur dans WPML.

Enjoy!

Exprimez vous!

*